세이박스

파워포인트 2010 대문자 자동 변환 해제

컴활용

파워포인터에서 영문 입력시 첫글자가 매번 대문자로 자동 변환되면 안되는 경우 편리하게 만들어 놓은 이 기능이 오히려 불편할때가 있죠.
설정에서 대문자 자동 변환 해제 설정할 수 있습니다.
 
파일 > 옵션 > 언어교정 > 자동고침옵션
 
* 문장의 첫 글자를 대문자로[the -> The]
 
라고 되어 있는 항목 체크를 끄면 자동 변환이 해제 됩니다.
이외에도 한영 자동 전환이라던지 기타 자동 설정을 바꿀수 있습니다.
 
 

file_get_contents() Warning 오류 해결 방법

웹프로그램
웹호스팅을 이용할 경우 php.ini 수정이 어려운 경우가 있습니다.
특히 외부의 파일을 가져올 경우 allow_url_fopen = 0; 일 경우 1로 수정 해줘야 하지만, 보안상 막아둔 경우 서버를 공용으로 사용하므로 수정을 해주지 않습니다.
저의 경우 cafe24 호스팅을 주로 이용하는데 이곳 역시 allow_url_fopen = 0 으로 되어 있어서 fopen(), file(), file_get_contents() 함수로 외부 URL 을 읽어 들이기가 안됩니다.
 
Warning: file_get_contents() URL file-access is disabled in the server configuration in
 
하지만, 오류를 해결하는 방법으로 외부 파일을 읽어 들이는 함수 이용전에 다음과 같이 ini 설정을 임시로 변경해서 사용하면 됩니다.
 
@ini_set("allow_url_fopen","1");
 
ini_set() 를 사용해서 해당 페이지에서 일시적으로 allow_url_fopen을 1로 적용해서 이용할 수 있습니다.
 
하지만, allow_url_fopen 이용시 보안상 취약합니다.
아래 cafe24 호스팅 업체로 부터 답변 받은 내용 입니다.
 
최근 발생하고 있는 홈페이지 변조나, 피싱 사이트로의 악용은 대부분 게시판의 취약점이나, php 의 취약점에 의해 발생되고 있습니다. 이중에 가장 빈번한 것이 php 의 외부 사이트 소스 실행 기능 (allow_url_fopen)으로 악의적인 프로그램이 실행되어져서 발생이 되고 있습니다.
이러한 문제로 인하여 한국정보보호진흥원에서는 allow_url_fopen 을 허용하지 않기를 권고 하고 있습니다.
allow_url_fopen 을 허용하게 되면 보안적으로 심각한 문제를 초래 할 수 있습니다.
해당 기능을 켜두게 되면, 원격에서 프로그램을 웹사이트에 삽입하여 실행(PHP injection), 대량으로 웹사이트를 변조 할 수 있게 되므로 어느날 갑자기, 홈페이지 화일이 통채로 지워지거나, 데이터베이스 내용이 모두 사라질수도 있습니다.
 
관련 내용 URL :
 
저희 카페24에서는 기본적으로 해당 기능이 모두 off 로 설정이 되어 있으며, 따라서 고객님께서는 가급적 allow_url_fopen 기능이외에 다른 방법으로 구현을 하시거나, 아래의 예시와 같은 function 을 만들어서 사용하시는 것을 권고합니다. (HttpRequest, http_get, fsockopen 등의 함수로 구현이 가능합니다.)
(allow_url_fopen 기능이란 php 에서 include 를 사용할때 URL 방식으로 파일을 include 할수 있도록 해주는 기능입니다.)
 
(해당 내용이 이해가 되지 않거나, 보안의 위험성을 감수하더라도 반드시 allow_url_fopen 을 사용하셔야 한다면, 고객센터로 연락을 주시면 친절히 상담해 드립니다.)
 
-----------------------------------------------------------------------------------------
function get_url_fsockopen( $url ) {
     $URL_parsed = parse_url($url);
     $host = $URL_parsed["host"];
     $port = $URL_parsed["port"];
     if ($port==0)
          $port = 80;
     $path = $URL_parsed["path"];
     if ($URL_parsed["query"] != "")
          $path .= "?".$URL_parsed["query"];
     $out = "GET $path HTTP/1.0\\r\\nHost: $host\\r\\n\\r\\n";
     $fp = fsockopen($host, $port, $errno, $errstr, 30);
     if (!$fp) {
          echo "$errstr ($errno)<br>\\n";
     } else {
          fputs($fp, $out);
          $body = false;
          while (!feof($fp)) {
          $s = fgets($fp, 128);
          if ( $body )
               $in .= $s;
          if ( $s == "\\r\\n" )
               $body = true;
          }
          fclose($fp);
          echo $in;
     }
}
-----------------------------------------------------------------------------------------
 
위 함수로도 동작 잘 되는군요.
 
 

Apache httpd.conf 에서 서브 도메인 redirect시 RewriteRule 적용

서버,보안

서브 도메인을 특정 도메인으로 redirect 할 경우 페이지를 찾을수 없는 경우가 발생하곤 하는데 이를 경우 방문자를 잃을수 있습니다.

예를들어 http://www.saybox.net 도메인으로 서비스를 하다가 어느날 http://www.saybox.co.kr 도메인으로 서비스를 이용하게 되어서
redirect / http://www.saybox.co.kr
처럼 redirect 할 경우 발생할 수 있는 문제점이 있습니다.

회원이 즐겨찾기 해둔 URL이 만약 http://www.saybox.co.kr/index.php 였다면 redirect에서 처리를 할 수 없게 됩니다.
그래서 뒤에 어떠한 URL 파라미터가 붙더라도 redirect 되도록 할려면 여러가지 방법이 있는데 그중 한가지가 RewriteEngine을 이용한 방법입니다.

일단, RewriteEngine을 On 해주시고, RewriteRule에 /.* 라고 적습니다.
즉, 도메인 / 뒤에 붙는 .* 모든 내용을 지정한 URL로 이동 시켜라 그런 내용입니다

<VirtualHost *:80>
..... 생략 ...
RewriteEngine On
RewriteRule /.* http://www.saybox.co.kr
</VirtualHost>


 

MySQL root 비번을 잊어버려서 접속을 못할 경우 패스워드 초기화 방법

데이타베이스

MySQL 설치하면서 비번을 잘못 입력(오타)하거나 기존 root 개정을 잊어 버린경우 다시 설치 하지 않고 비번만 변경할수 있습니다.
기존 MySQL 프로세스 종료하고 안전모드로 접속한후에 개정 테이블(user)에서 root 패스워드를 변경하는 방법입니다.

# MySQL 프로세스 죽이기
/etc/init.d/mysqld stop
killall mysqld

# MySQL 안전모드 접속후 root 비번 변경
cd /usr/local/mysql/bin
./mysqld_safe --skip-grant &
use mysql;
update user set password=password('비밀번호') where user='root';
FLUSH PRIVILEGES;
exit;

# 접속확인
mysql -uroot -p mysql

비번 입력후 mysql> 접속이 잘되면 성공입니다.


 ▶ 최신영화, 최신 미국드라마 무료 다운로드..

자바스크립트 이용해서 다음 카페 대문에 iframe 삽입하기

웹프로그램
사용자 삽입 이미지


다음 카페 대문에 광고 삽입되는것을 보고서 어떻게 구현하는 것일까?
고민하다가 소스를 보니 자바스크립트를 이용하고 있더군요.
일단, 다음 카페 설정에서 대문 설정이 있는데 html 모드로 설정 하시면 태그를 입력 할 수 있습니다.

사용자 삽입 이미지


하지만, <iframe></iframe> 태그는 사용할수 없도록 차단하고 있습니다.
차단 방법이 iframe 단어로 차단하고 있으므로 ifr ame 을 분리 하면됩니다.
하지만 이렇게 태그를 분리하면 iframe 동작을 못하게 됩니다.
따라서, 자바스크립트의 document.write() 를 이용해서 출력해주면 됩니다.

<scRIPT>document.write("<IFR"+"AME height=710 src='http://도메인' frameBorder=0 width=778 height=162 scrolling=no></IFR"+"AME>");</scRIPT>

위 소스처럼 "<ifr"+"ame ..." 으로 분리 해버리면 실제 출력은 "<iframe"으로 되지만 다음카페에서 차단 분석시에는 예외 처리 되어 버립니다.
이로써 카페 대문에 광고 및 필요한 내용을 외부로 부터 가져와서 보여 줄수가 있겠죠.
잘 응용해보세요.

제가 달인쿠폰 배너를 샘플로 제 임시 다음카페에 적용해 봤습니다.
참조 : http://cafe.daum.net/sayboxs


 ▶ 최신영화, 최신 미국드라마 무료 다운로드...

Adobe Illust 10.0 환경설정 초기화 하기

디자인
일러스트 이용중에 설정이 문제가 생겨 다시 재설치 해도 이전 설정되로 설치가 되는경우가 있죠.
일러스트를 다시 설치하면서 기본 환경 설정 파일이 제대로 안지워 져서 그렇습니다.
환경설정파일은 내문서에 숨겨져 있습니다.
따라서, 환경설정 파일을 지우면 됩니다.

파일위치는
C:\Documents and Settings\로그인아이디\application data\adobe\illustrator 10

사용자 삽입 이미지


안에 있습니다.

문제는 해당 폴더들이 숨겨져 있는데 숨겨져 있는 폴더나 파일을 볼려면 탐색기 메뉴에서 설정을 변경 하셔야 합니다.

도구 > 폴더 옵션 > 보기 > 고급설정 > 숨김 파일 및 폴더 > 숨김 파일 및 폴더 표시

사용자 삽입 이미지


에 체크를 하시면 보입니다.

AIPrefs 파일을 지우면 처음 설치 했을때와 같이 되돌아갑니다.

위 글은 세이박스에서 작성 한 글입니다. 내용 변경은 하시면 안되며 아래 출처를 반드시 남기셔야 합니다.
출처 : http://saybox.tistory.com/1162

Alteon AD3 설정 메뉴얼

서버,보안
 
► Alteon AceDirector 3 (AD3) 장비 설정
1. 콘솔 터미널 연결 설정
1-1. 콘솔 연결 및 하이퍼터미널 실행(시작 -> 프로그램 -> 보조프로그램 -> 통신 -> 하이퍼터미널)
Bits per second (baud): 9600
Data bits: 8
Parity: None
Stop bits: 1
Flow Control: Xon/Xoff
1-2. 부팅후 기본 패스워드로 로그인
Version 10.0.32.1 from FLASH image1, factory default config block.
 
Enter password:adminß----------화면에 표시되지 않음 (기본 패스워드)
System Information at 9:23:27 Fri Mar 9, 2007
 
Alteon AD3
sysName:
sysLocation:
 
Switch is up 0 days, 0 hours, 0 minutes and 22 seconds.
Last boot: 9:23:04 Fri Mar 9, 2007 (reset from console)
 
MAC address: aa:aa:aa:aa:aa:aa    IP (If 1) address: 0.0.0.0
Hardware Revision: B
Hardware Part No: AAA_AA-A_AA-A
Software Version 10.0.32.1-SSH (FLASH image1), factory default configuration.
 
------------------------------------------------------------
[Main Menu]
      info    - Information Menu
      stats   - Statistics Menu
      cfg     - Configuration Menu
      oper    - Operations Command Menu
      boot    - Boot Options Menu
      maint   - Maintenance Menu
      diff    - Show pending config changes [global command]
      apply   - Apply pending config changes [global command]
      save    - Save updated config to FLASH [global command]
      revert - Revert pending or applied changes [global command]
      exit    - Exit [global command, always available]
 
>> Main#
 
2. IP 설정
2-1. IP 설정 메뉴
>> Main# /cfg/ip
------------------------------------------------------------
[IP Menu]
      if      - Interface Menu
      gw      - Default Gateway Menu
      route   - Static Route Menu
      frwd    - Forwarding Menu
      rip1    - Routing Information Protocol Menu
      bgp     - Border Gateway Protocol Menu
      port    - IP Port Menu
      dns     - Domain Name System Menu
      bootp   - Bootstrap Protocol Relay Menu
      rearp   - Set re-ARP period in minutes
      metrc   - Set default gateway metric
      cur     - Display current IP configuration
 
>> IP#
2-2. IP 설정 예시
>> IP# if
Enter interface number: (1-256) 1
------------------------------------------------------------
[IP Interface 1 Menu]
      addr    - Set IP address
      mask    - Set subnet mask
      broad   - Set broadcast address
      vlan    - Set VLAN number
      relay   - Enable/disable BOOTP relay
      ena     - Enable IP interface
      dis     - Disable IP interface
      del     - Delete IP interface
      cur     - Display current interface configuration
 
>> IP Interface 1# addr 192.168.2.200/mask 255.255.255.0/br 192.168.2.255
Current IP address:     192.168.2.199
New pending IP address: 192.168.2.200
Current subnet mask:     255.255.255.0
New pending subnet mask: 255.255.255.0
Current broadcast address:     192.168.2.255
New pending broadcast address: 192.168.2.255
 
>> IP Interface 1# ena
Current status: enabled
New status:     enabled
 
>> IP Interface 1#
2-3. Gateway 설정 예시
>> IP# gw
Enter default gateway number: (1-4) 1
------------------------------------------------------------
[Default gateway 1 Menu]
      addr    - Set IP address
      intr    - Set interval between ping attempts
      retry   - Set number of failed attempts to declare gateway DOWN
      arp     - Enable/disable ARP only health checks
      ena     - Enable default gateway
      dis     - Disable default gateway
      del     - Delete default gateway
      cur     - Display current default gateway configuration
 
>> Default gateway 1# addr 192.168.2.1
Current IP address:     192.168.2.1
New pending IP address: 192.168.2.1
 
>> Default gateway 1# ena
Current status: enabled
New status:     enabled
 
>> Default gateway 1#
2-4. IP 설정 확인 (apply 명령어로 적용시킨후 확인 가능)
>> IP# cur
Current IP configuration:
 rearp 10, gw metric strict
 
Current interfaces:
 1: 192.168.2.200   255.255.255.0   192.168.2.255,   vlan 1, enabled
 
Current default gateways:
 1: 192.168.2.1,     intr 2, retry 8, arp disabled, enabled
 
Current static routes:
 
Current IP forwarding settings: ON, dirbr disabled
 
Current local networks:
 
Current IP port settings:
 1: ON
 2: ON
 3: ON
 4: ON
 5: ON
 6: ON
 7: ON
 8: ON
 9: ON
 
Current RIP settings:
 OFF, update 30
 split horizon
 
Current BGP configuration: OFF
 
Current BGP peer configuration:
 
Current BGP filter configuration:
 
Current DNS settings:
 0.0.0.0, 0.0.0.0, none
 
Current BOOTP relay settings: OFF
 0.0.0.0, 0.0.0.0
Note: there are pending config changes; use "diff" to see them.
 
3. 포트 링크 설정
3-1. 포트 모드 설정 및 스피드 설정
# /cfg/po 1[포트번호]
# fast
# speed 100
# mode full
# auto off
 
3-2. auto negotiation 설정
# /cfg/po 1[포트번호]
# fast
# speed any
# mode any
# auto on
 
4. SLB(Server Load Balancing)
4-1. SLB 설정 메뉴
>> Main# cfg/slb
------------------------------------------------------------
[Layer 4 Menu]
      real    - Real Server Menu
      group   - Real Server Group Menu
      virt    - Virtual Server Menu
      filt    - Filtering Menu
      port    - Layer 4 Port Menu
      gslb    - Global SLB Menu
      layer7 - Layer 7 Resource Definition Menu
      sync    - Config Synch Menu
      adv     - Layer 4 Advanced Menu
      on      - Globally turn Layer 4 processing ON
      off     - Globally turn Layer 4 processing OFF
      cur     - Display current Layer 4 configuration
4-2. 리얼 서버 설정
>> Layer 4# real 1
------------------------------------------------------------
[Real server 1 Menu]
      layer7 - Layer 7 Command Menu
      rip     - Set IP addr of real server
      name    - Set server name
      weight - Set server weight
      maxcon - Set maximum number of connections
      tmout   - Set minutes inactive connection remains open
      backup - Set backup real server
      inter   - Set interval between health checks
      retry   - Set number of failed attempts to declare server DOWN
      restr   - Set number of successful attempts to declare server UP
      addport - Add real port to server
      remport - Remove real port from server
      remote - Enable/disable remote site operation
      proxy   - Enable/disable client proxy operation
      submac - Enable/disable source MAC address substitution
      ena     - Enable real server
      dis     - Disable real server
      del     - Delete real server
      cur     - Display current real server configuration
# /cfg/slb/real 1    <-   리얼서버 번호 1 지정
# rip 192.168.2.101
# enable
# /cfg/slb/real 1    <-   리얼서버 번호 2 지정
# rip 192.168.2.102
# enable
 
# /cfg/slb/real 1    <-   리얼서버 번호 3 지정
# rip 192.168.2.103
# enable
 
 
 
 
 
4-3. 리얼 서버 그룹 설정
>> Main# cfg/slb/group 1
------------------------------------------------------------
[Real server group 1 Menu]
      metric - Set metric used to select next server in group
      content - Set health check content
      health - Set health check type
      backup - Set backup real server or group
      name    - Set real server group name
      realthr - Set real server failure threshold
      viphlth - Enable/disable VIP health checking in DSR mode
      add     - Add real server
      rem     - Remove real server
      del     - Delete real server group
      cur     - Display current group configuration
 
# add 1/add 2/add 3 <- 리얼 IP 를 그룹 1번에 지정
# health http     <- Health Check 타입을 설정
health link|arp|icmp|tcp|http|dns|pop3|smtp|nntp|ftp|imap|radius|sslh|script-x<n>|udpdns|ldap
# metric hash    <- metric hash 방식으로 지정(동일한 유저로 부터의 서비스요청 – 동일한 서버연결)
metric leastconns|roundrobin|minmisses|hash|response|bandwidth
 
4-4. 가상 서버 설정
>> Main# cfg/slb/virt 1
------------------------------------------------------------
[Virtual Server 1 Menu]
      service - Virtual Service Menu
      vip     - Set IP addr of virtual server
      dname   - Set domain name of virtual server
      layr3   - Enable/disable layer 3 only balancing
      ena     - Enable virtual server
      dis     - Disable virtual server
      del     - Delete virtual server
      cur     - Display current virtual configuration
 
# vip 192.168.2.100 <- virtual IP 지정
# enable
# service http <- 서비스 포트 번호, Well-Known 포트의 경우는 서비스 이름으로 지정
4-5. 클라이언트 / 서버 포트 지정
>> Main# cfg/slb/port 1
------------------------------------------------------------
[SLB port 1 Menu]
      client - Enable/disable client processing
      server - Enable/disable server processing
      rts     - Enable/disable RTS processing

출처 : http://www.nicehosting.co.kr/customer/customer_09_view.asp?seqno=25&ctype=1&ktype=3

Cisco L2, L3 스위치 VLAN 설정 방법

서버,보안
 
Cisco L2, L3 스위치 VLAN 설정 방법
  ex) C2950, C3550, C4506,...
 
※ 신규 IP대역이 추가되어, 해당 IP대역을 신규 VLAN에 할당하여 관리할 경우 사용
 
1. 우선 새로운 VLAN을 추가
>interface Vlan 101
> ip address 1.2.3.4 255.255.255.128
> no ip redirects
> standby 101 ip 1.2.3.1                    ; 게이트웨이 IP주소 설정
> standby 101 timers 1 3
> standby 101 priority 100                  ; 우선순위는 상황에 따라서...
> standby 101 preempt
 
2. 사용하고자 하는 포트에 새로 추가한 VLAN을 할당
>interface FastEthernet 0/20
> switchport access vlan 101
> switchport mode access
> no ip address
 
3. 필요 시 span tree 설정 작업
> spanning-tree vlan 100-101 priority 4000         ; C4506의 경우
  또는
 > spanning-tree vlan 100 priority 4000              ; C3550 이나
 > spanning-tree vlan 101 priority 4000              ; C2950의 경우
 
※ C2950의 경우 L2 스위치 이므로 VLAN간 통신이 불가능함
    -> 실제로 설정해 본 결과, 동시에 하나의 VLAN만 활성화됨
    -> 즉 사용하고자 하는 VLAN을 활성화하면 나머지 VLAN은 shutdown됨
    -> 이로 인해 C2950의 VLAN설정은 콘솔로만 가능, 원격에서는 설정불가

PHP W3C P3P 규약설정

웹프로그램
// W3C P3P 규약설정
@header ("P3P : CP=\"ALL CURa ADMa DEVa TAIa OUR BUS IND PHY ONL UNI PUR FIN COM NAV INT DEM CNT STA POL HEA PRE LOC OTC\"");

IE6 부터... 바뀐 쿠키 설정에 따른 설정법

PHP 파일 업로드시 권한 설정

웹프로그램

if(!is_dir($saveDir)) {
$oldumask = umask(0);
mkdir($saveDir, 0777); // or even 01777 so you get the sticky bit set
umask($oldumask);
}

이때...

umask란 file이 생성될 때 사용할 file의 권한에 대해 mask를 인코딩하는 system 변수이다.

보통 3자리로 표현이 되며 각각의 자리는 user, group, other의 권한을 나타낸다.

umake의 값은 3자리의 8진수의 값이며 각각의 값은 1,2,4의 값은 AND 연산한 결과이다.

0 : 사용자에게 모든 권한을 혀용.
4 : 사용자에게 읽기 권한은 주지 않음.
2 : 사용자에게 쓰기 권한을 주지 않음.
1 : 사용자에게 실행 권한을 주지 않음.

간단하게 예를 들어서 설명을 해 보면 umask 022 는 user에게는 모든 권한을 주며, group과 other에는 실행 권한과 읽기 권한만 주는 것이다.

즉 -rwxr-xr-x의 퍼미션을 나타낸다.

그러면 하나의 예를 더 들어 보면 -rxw--x--x 의 퍼미션을 지정하려면 group과 other에게 읽기와 쓰기의 권한을 주지 않는 2,4를 지정하는데 위에서 AND연산의 결과값이기 때문에 6이 된다. 즉 umask 066이 되는 것이다.